GitHub Advisoryadvisory · npm
GHSA-4jv9-3563-23j3 Knex.js has a limited SQL injection vulnerability
HIGH
Official page ↗
- Aliases
- CVE-2016-20018
- Ecosystem
- npm
- Packages
- knex
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- Weaknesses
- CWE-89
- Reviewed
- 2022-12-20
Affected packages
• npm knex: < 2.4.0 → fixed in 2.4.0
Description
Knex Knex.js through 2.3.0 has a limited SQL injection vulnerability that can be exploited to ignore the WHERE clause of a SQL query. This vulnerability has been fixed in version 2.4.0.
Related
Alias · CVE (1)
- CVE-2016-20018 Knex Knex.js through 2.3.0 has a limited SQL injection vulnerability that can be exploited to ignore the WHERE clause of a SQL query. vulnerability
Weakness · CWE (1)
- CWE-89 Improper Neutralization of Special Elements used in an SQL Command weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2016-20018 advisory
- https://github.com/knex/knex/issues/1227 web
- https://github.com/knex/knex/pull/5417 web
- https://github.com/knex/knex/commit/e145322da92749be7749f9ade5b5f5a66d6586a4 web
- https://github.com/knex/knex package
- https://github.com/knex/knex/releases/tag/2.4.0 web
- https://www.ghostccamm.com/blog/knex_sqli web