GitHub Advisoryadvisory · npm

GHSA-4m3m-ppvx-xgw9 Session fixation in fastify-passport

HIGH Published 2023-04-21 Modified 2023-04-24 Official page ↗
Aliases
CVE-2023-29019
Ecosystem
npm
Packages
@fastify/passport
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N
Weaknesses
CWE-384
Reviewed
2023-04-21

Affected packages

• npm @fastify/passport: < 1.1.0 → fixed in 1.1.0 • npm @fastify/passport: >= 2.0.0, < 2.3.0 → fixed in 2.3.0

Description

Applications using `@fastify/passport` for user authentication, in combination with `@fastify/session` as the underlying session management mechanism, are vulnerable to session fixation attacks from network and same-site attackers. Details fastify applications rely on the `@fastify/passport` library for user authentication. The login and user validation are performed by the `authenticate` function. When executing this function, the `sessionId` is preserved between the pre-login and the authenticated session. Network and same-site attackers can hijack the victim's session by tossing a valid `sessionId` cookie in the victim's browser and waiting for the victim to log in on the website. Fix As a solution, newer versions of `@fastify/passport` regenerate `sessionId` upon login, preventing the attacker-controlled pre-session cookie from being upgraded to an authenticated session. Credits • Pedro Adão (@pedromigueladao), Instituto Superior Técnico, University of Lisbon • Marco Squarcina (@lavish), Security & Privacy Research Unit, TU Wien

Related

Alias · CVE (1)

  • CVE-2023-29019 @fastify/passport is a port of passport authentication library for the Fastify ecosystem. vulnerability

Weakness · CWE (1)

  • CWE-384 Session Fixation weakness

References