GitHub Advisoryadvisory · Packagist
GHSA-4m7h-34xm-4wjv Concrete CMS Stored Cross-site Scripting vulnerability
LOW
Official page ↗
- Aliases
- CVE-2024-2179
- Ecosystem
- Packagist
- Packages
- concrete5/concrete5
- Severity
- Low
- CVSS vector
- CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:L/I:N/A:N
- Weaknesses
- CWE-20, CWE-79
- Reviewed
- 2024-03-06
Affected packages
• Packagist concrete5/concrete5: < 9.2.7 → fixed in 9.2.7
Description
Concrete CMS version 9 before 9.2.7 is vulnerable to Stored XSS via the Name field of a Group type since there is insufficient validation of administrator provided data for that field. A rogue administrator could inject malicious code into the Name field which might be executed when users visit the affected page. The Concrete CMS security team gave this vulnerability a CVSS v3.1 score of 2.2 with a vector of AV:N/AC:H/PR:H/UI:N/S:U/C:L/I:N/A:N Concrete versions below 9 do not include group types so they are not affected by this vulnerability. Thanks Luca Fuda for reporting.
Related
Alias · CVE (1)
- CVE-2024-2179 Concrete CMS version 9 before 9.2.7 is vulnerable to Stored XSS via the Name field of a Group type since there is insufficient validation… vulnerability
References
- https://nvd.nist.gov/vuln/detail/CVE-2024-2179 advisory
- https://github.com/concretecms/concretecms/commit/ac1ec9b069acac79869b2988e1f56cc5565a3dd4 web
- https://documentation.concretecms.org/9-x/developers/introduction/version-history/927-release-notes web
- https://github.com/concretecms/concretecms package