GitHub Advisoryadvisory · Maven
GHSA-4mp9-239f-g9hg Netty: WebSockets V07/V08 handshaker missing Connection/Upgrade validation
MEDIUM
Official page ↗
- Aliases
- CVE-2026-59898
- Ecosystem
- Maven
- Packages
- io.netty:netty-codec-http
- Severity
- Moderate
- CVSS vector
- CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N
- Weaknesses
- CWE-444
- Reviewed
- 2026-07-22
Affected packages
• Maven io.netty:netty-codec-http: >= 4.2.0.Final, < 4.2.16.Final → fixed in 4.2.16.Final
• Maven io.netty:netty-codec-http: < 4.1.136.Final → fixed in 4.1.136.Final
Description
Summary
An attacker can force WebSocket upgrade via the lax V07 (or V08) handshaker by sending `Sec-WebSocket-Version: 7` and omitting `Connection: Upgrade` / `Upgrade: websocket` headers, completing a protocol switch that a proxy would not recognize as an Upgrade request and enabling HTTP request smuggling / protocol-confusion attacks.
Related
Alias · CVE (1)
- CVE-2026-59898 Netty is an asynchronous, event-driven network application framework. vulnerability
Weakness · CWE (1)
- CWE-444 Inconsistent Interpretation of HTTP Requests weakness