GitHub Advisoryadvisory · PyPI
GHSA-4mr4-7vjv-9hm6 Mercurial Incorrect Access Control vulnerability
CRITICAL
Official page ↗
- Aliases
- CVE-2018-1000132
- Ecosystem
- PyPI
- Packages
- mercurial
- Severity
- Critical
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
- Weaknesses
- CWE-732
- Reviewed
- 2024-05-01
Affected packages
• PyPI mercurial: < 4.5.1 → fixed in 4.5.1
Description
Mercurial version 4.5 and earlier contains a Incorrect Access Control (CWE-285) vulnerability in Protocol server that can result in Unauthorized data access. This attack appear to be exploitable via network connectivity. This vulnerability appears to have been fixed in 4.5.1.
Related
Alias · CVE (1)
- CVE-2018-1000132 Mercurial version 4.5 and earlier contains a Incorrect Access Control (CWE-285) vulnerability in Protocol server that can result in… vulnerability
Weakness · CWE (1)
- CWE-732 Incorrect Permission Assignment for Critical Resource weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2018-1000132 advisory
- https://access.redhat.com/errata/RHSA-2019:2276 web
- https://github.com/pypa/advisory-database/tree/main/vulns/mercurial/PYSEC-2018-87.yaml web
- https://lists.debian.org/debian-lts-announce/2018/03/msg00034.html web
- https://lists.debian.org/debian-lts-announce/2018/07/msg00005.html web
- https://lists.debian.org/debian-lts-announce/2020/07/msg00032.html web
- https://www.mercurial-scm.org/wiki/WhatsNew#Mercurial_4.5.1_.2F_4.5.2_.282018-03-06.29 web