GitHub Advisoryadvisory · npm

GHSA-4mxg-3p6v-xgq3 Node-SAML SAML Signature Verification Vulnerability

CRITICAL Published 2025-07-28 Modified 2025-08-08 Official page ↗
Aliases
CVE-2025-54419
Ecosystem
npm
Packages
@node-saml/node-saml, passport-saml, @node-saml/passport-saml
Severity
Critical
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:N
Weaknesses
CWE-287, CWE-347
Reviewed
2025-07-28

Affected packages

• npm @node-saml/node-saml: < 5.1.0 → fixed in 5.1.0 • npm passport-saml: <= 3.2.4 (no fix yet) • npm @node-saml/passport-saml: < 5.1.0 → fixed in 5.1.0

Description

Node-SAML loads the assertion from the (unsigned) original response document. This is different than the parts that are verified when checking signature. This allows an attacker to modify authentication details within a valid SAML assertion. For example, in one attack it is possible to remove any character from the SAML assertion username. To conduct the attack an attacker would need a validly signed document from the identity provider (IdP). In fixing this we made sure to process the SAML assertions from only verified/authenticated contents. This will prevent future variants from coming up. Note: this is distinct from the previous xml-crypto CVEs.

Related

Alias · CVE (1)

  • CVE-2025-54419 A SAML library not dependent on any frameworks that runs in Node. vulnerability

Weakness · CWE (2)

  • CWE-287 Improper Authentication weakness
  • CWE-347 Improper Verification of Cryptographic Signature weakness

References