GitHub Advisoryadvisory · npm
GHSA-4pg4-qvpc-4q3h Multer vulnerable to Denial of Service from maliciously crafted requests
HIGH
Official page ↗
- Aliases
- CVE-2025-47944
- Ecosystem
- npm
- Packages
- multer
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-248
- Reviewed
- 2025-05-19
Affected packages
• npm multer: >= 1.4.4-lts.1, < 2.0.0 → fixed in 2.0.0
Description
Impact
A vulnerability in Multer versions >=1.4.4-lts.1 allows an attacker to trigger a Denial of Service (DoS) by sending a malformed multi-part upload request. This request causes an unhandled exception, leading to a crash of the process.
Patches
Users should upgrade to `2.0.0`
Workarounds
None
References
• https://github.com/expressjs/multer/issues/1176
• https://github.com/expressjs/multer/commit/2c8505f207d923dd8de13a9f93a4563e59933665
Related
Alias · CVE (1)
- CVE-2025-47944 Multer is a node.js middleware for handling `multipart/form-data`. vulnerability
Weakness · CWE (1)
- CWE-248 Uncaught Exception weakness
References
- https://github.com/expressjs/multer/security/advisories/GHSA-4pg4-qvpc-4q3h web
- https://nvd.nist.gov/vuln/detail/CVE-2025-47944 advisory
- https://github.com/expressjs/multer/issues/1176 web
- https://github.com/expressjs/multer/commit/2c8505f207d923dd8de13a9f93a4563e59933665 web
- https://github.com/expressjs/multer package