GitHub Advisoryadvisory · Packagist

GHSA-4ppg-2mx6-fqx9 Moodle allows attackers to bypass intended login restrictions

LOW Published 2022-05-13 Modified 2024-01-26 Official page ↗
Aliases
CVE-2015-3179
Ecosystem
Packagist
Packages
moodle/moodle
Severity
Low
Reviewed
2024-01-26

Affected packages

• Packagist moodle/moodle: < 2.6.11 → fixed in 2.6.11 • Packagist moodle/moodle: >= 2.7.0, < 2.7.8 → fixed in 2.7.8 • Packagist moodle/moodle: >= 2.8.0, < 2.8.6 → fixed in 2.8.6

Description

login/confirm.php in Moodle through 2.5.9, 2.6.x before 2.6.11, 2.7.x before 2.7.8, and 2.8.x before 2.8.6 allows remote authenticated users to bypass intended login restrictions by leveraging access to an unconfirmed suspended account.

Related

Alias · CVE (1)

  • CVE-2015-3179 login/confirm.php in Moodle through 2.5.9, 2.6.x before 2.6.11, 2.7.x before 2.7.8, and 2.8.x before 2.8.6 allows remote authenticated… vulnerability

References