GitHub Advisoryadvisory · Maven

GHSA-4prj-vw9j-v6pr Arbitrary code execution in Apache Struts 2

CRITICAL Published 2022-05-14 Modified 2023-12-28 Official page ↗
Aliases
CVE-2016-4438
Ecosystem
Maven
Packages
org.apache.struts:struts2-core, org.apache.struts:struts2-rest-plugin
Severity
Critical
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-20
Reviewed
2022-11-03

Affected packages

• Maven org.apache.struts:struts2-core: >= 2.3.19, < 2.3.29 → fixed in 2.3.29 • Maven org.apache.struts:struts2-rest-plugin: >= 2.3.19, < 2.3.29 → fixed in 2.3.29

Description

The REST plugin in Apache Struts 2 2.3.19 through 2.3.28.1 allows remote attackers to execute arbitrary code via a crafted expression.

Related

Alias · CVE (1)

  • CVE-2016-4438 The REST plugin in Apache Struts 2 2.3.19 through 2.3.28.1 allows remote attackers to execute arbitrary code via a crafted expression. vulnerability

Weakness · CWE (1)

  • CWE-20 Improper Input Validation weakness

References