GitHub Advisoryadvisory · RubyGems

GHSA-4q53-fqhc-cr46 ember-source Cross-site Scripting vulnerability

LOW Published 2018-08-28 Modified 2025-08-11 Official page ↗
Aliases
CVE-2014-0046
Ecosystem
RubyGems
Packages
ember-source
Severity
Low
Weaknesses
CWE-79
Reviewed
2020-06-16

Affected packages

• RubyGems ember-source: >= 1.2.0, < 1.2.2 → fixed in 1.2.2 • RubyGems ember-source: >= 1.3.0, < 1.3.2 → fixed in 1.3.2 • RubyGems ember-source: >= 1.4.0.beta.1, < 1.4.0.beta.6 → fixed in 1.4.0.beta.6

Description

Cross-site scripting (XSS) vulnerability in the link-to helper in Ember.js 1.2.x before 1.2.2, 1.3.x before 1.3.2, and 1.4.x before 1.4.0-beta.6, when used in non-block form, allows remote attackers to inject arbitrary web script or HTML via the title attribute.

Related

Alias · CVE (1)

  • CVE-2014-0046 Cross-site scripting (XSS) vulnerability in the link-to helper in Ember.js 1.2.x before 1.2.2, 1.3.x before 1.3.2, and 1.4.x before… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References