GitHub Advisoryadvisory · Maven

GHSA-4qw8-pgpr-p9mq Bash command injection in Apache Zeppelin

CRITICAL Published 2021-09-07 Modified 2023-11-27 Official page ↗
Aliases
CVE-2019-10095
Ecosystem
Maven
Packages
org.apache.zeppelin:zeppelin
Severity
Critical
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-77, CWE-78
Reviewed
2021-09-03

Affected packages

• Maven org.apache.zeppelin:zeppelin: < 0.10.0 → fixed in 0.10.0

Description

bash command injection vulnerability in Apache Zeppelin allows an attacker to inject system commands into Spark interpreter settings. This issue affects Apache Zeppelin Apache Zeppelin version 0.9.0 and prior versions.

Related

Alias · CVE (1)

  • CVE-2019-10095 bash command injection vulnerability in Apache Zeppelin allows an attacker to inject system commands into Spark interpreter settings. vulnerability

Weakness · CWE (2)

  • CWE-77 Improper Neutralization of Special Elements used in a Command weakness
  • CWE-78 Improper Neutralization of Special Elements used in an OS Command weakness

References