GitHub Advisoryadvisory · Packagist
GHSA-4qx8-j9vh-2628 silverstripe/framework's User-Agent header not correctly invalidating user session
HIGH
Official page ↗
- Ecosystem
- Packagist
- Packages
- silverstripe/framework
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- Weaknesses
- CWE-384
- Reviewed
- 2024-05-27
Affected packages
• Packagist silverstripe/framework: >= 3.5.0-rc1, < 3.5.6 → fixed in 3.5.6
• Packagist silverstripe/framework: >= 3.6.0-rc1, < 3.6.3 → fixed in 3.6.3
Description
A security protection device in Session designed to protect session hijacking was not correctly functioning. This function intended to protect user sessions by detecting changes in the User-Agent header, but modifications to this header were not correctly invalidating the user session.
Related
Weakness · CWE (1)
- CWE-384 Session Fixation weakness
References
- https://github.com/silverstripe/silverstripe-framework/commit/44de03da0147e6094b02602b7b73d5b1a1306d78 web
- https://github.com/silverstripe/silverstripe-framework/commit/d47667bb0768841e4b305fa95d5a4e2ba232c4ad web
- https://github.com/FriendsOfPHP/security-advisories/blob/master/silverstripe/framework/SS-2017-006-1.yaml web
- https://github.com/silverstripe/silverstripe-framework package
- https://www.silverstripe.org/download/security-releases/ss-2017-006 web