GitHub Advisoryadvisory · Maven

GHSA-4r7g-7cpj-5jr7 Apache Qpid Broker-J vulnerable to Denial of Service (DoS) via uncontrolled resource consumption

HIGH Published 2018-10-19 Modified 2023-08-28 Official page ↗
Aliases
CVE-2017-15701
Ecosystem
Maven
Packages
org.apache.qpid:qpid-broker
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weaknesses
CWE-400
Reviewed
2020-06-16

Affected packages

• Maven org.apache.qpid:qpid-broker: >= 6.1.0, < 6.1.5 → fixed in 6.1.5

Description

In Apache Qpid Broker-J versions 6.1.0 through 6.1.4 (inclusive) the broker does not properly enforce a maximum frame size in AMQP 1.0 frames. A remote unauthenticated attacker could exploit this to cause the broker to exhaust all available memory and eventually terminate. Older AMQP protocols are not affected.

Related

Alias · CVE (1)

  • CVE-2017-15701 In Apache Qpid Broker-J versions 6.1.0 through 6.1.4 (inclusive) the broker does not properly enforce a maximum frame size in AMQP 1.0… vulnerability

Weakness · CWE (1)

  • CWE-400 Uncontrolled Resource Consumption weakness

References