GitHub Advisoryadvisory · Pub
GHSA-4rgh-jx4f-qfcq http before 0.13.3 vulnerable to header injection
MEDIUM
Official page ↗
- Aliases
- CVE-2020-35669
- Ecosystem
- Pub
- Packages
- http
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-74
- Reviewed
- 2022-08-04
Affected packages
• Pub http: < 0.13.3 → fixed in 0.13.3
Description
An issue was discovered in the http package before 0.13.3 for Dart. If the attacker controls the HTTP method and the app is using Request directly, it's possible to achieve CRLF injection in an HTTP request via HTTP header injection. This issue has been addressed in commit abb2bb182 by validating request methods.
Related
Alias · CVE (1)
- CVE-2020-35669 An issue was discovered in the http package through 0.12.2 for Dart. vulnerability
Weakness · CWE (1)
- CWE-74 Improper Neutralization of Special Elements in Output Used by a Downstream Component weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2020-35669 advisory
- https://github.com/dart-lang/http/issues/511 web
- https://github.com/dart-lang/http/pull/512 web
- https://github.com/dart-lang/http/commit/abb2bb182fbd7f03aafd1f889b902d7b3bdb8769 web
- https://github.com/dart-lang/http package
- https://github.com/dart-lang/http/blob/master/CHANGELOG.md#0133 web
- https://pub.dev/packages/http/changelog#0133 web