GitHub Advisoryadvisory · Packagist
GHSA-4rmj-w58m-fvch Moodle vulnerable to Server-Side Request Forgery
HIGH
Official page ↗
- Aliases
- CVE-2021-36396
- Ecosystem
- Packagist
- Packages
- moodle/moodle
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- Weaknesses
- CWE-918
- Reviewed
- 2023-03-07
Affected packages
• Packagist moodle/moodle: >= 3.11.0-beta, < 3.11.1 → fixed in 3.11.1
• Packagist moodle/moodle: >= 3.10.0-beta, < 3.10.5 → fixed in 3.10.5
• Packagist moodle/moodle: < 3.9.8 → fixed in 3.9.8
Description
In Moodle, insufficient redirect handling made it possible to blindly bypass cURL blocked hosts/allowed ports restrictions, resulting in a blind SSRF risk.
Related
Alias · CVE (1)
- CVE-2021-36396 In Moodle, insufficient redirect handling made it possible to blindly bypass cURL blocked hosts/allowed ports restrictions, resulting in a… vulnerability
Weakness · CWE (1)
- CWE-918 Server-Side Request Forgery weakness