GitHub Advisoryadvisory · Packagist
GHSA-4rmr-c2jx-vx27 Mustache remote code injection vulnerability
HIGH
Official page ↗
- Aliases
- CVE-2022-0323
- Ecosystem
- Packagist
- Packages
- mustache/mustache
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-1336, CWE-94
- Reviewed
- 2022-01-24
Affected packages
• Packagist mustache/mustache: >= 2.0.0, < 2.14.1 → fixed in 2.14.1
Description
In Mustache.php v2.0.0 through v2.14.0, Sections tag can lead to arbitrary php code execution even if strict_callables is true when section value is controllable.
Related
Alias · CVE (1)
- CVE-2022-0323 Improper Neutralization of Special Elements Used in a Template Engine in Packagist mustache/mustache prior to 2.14.1. vulnerability
References
- https://nvd.nist.gov/vuln/detail/CVE-2022-0323 advisory
- https://github.com/bobthecow/mustache.php/commit/579ffa5c96e1d292c060b3dd62811ff01ad8c24e web
- https://github.com/FriendsOfPHP/security-advisories/blob/master/mustache/mustache/CVE-2022-0323.yaml web
- https://github.com/bobthecow/mustache.php package
- https://github.com/bobthecow/mustache.php/releases/tag/v2.14.1 web
- https://huntr.dev/bounties/a5f5a988-aa52-4443-839d-299a63f44fb7 web