GitHub Advisoryadvisory · PyPI
GHSA-4v3r-hqr9-69jf Command Injection in Nuitka
HIGH
Official page ↗
- Aliases
- CVE-2022-2054
- Ecosystem
- PyPI
- Packages
- Nuitka
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-77, CWE-94
- Reviewed
- 2022-06-23
Affected packages
• PyPI Nuitka: < 0.9 → fixed in 0.9
Description
Nuitka 0.8.4 and prior is vulnerable to command injection. A patch is available and anticipated to be part of the `0.9` release.
Related
Alias · CVE (1)
- CVE-2022-2054 Code Injection in GitHub repository nuitka/nuitka prior to 0.9. vulnerability
References
- https://nvd.nist.gov/vuln/detail/CVE-2022-2054 advisory
- https://github.com/Nuitka/Nuitka/commit/1765ffce2a9ab859853210337390de242cd80712 web
- https://github.com/nuitka/nuitka/commit/09647745d7cbb6ff32f9fa948f19d5558b32bcad web
- https://github.com/nuitka/nuitka package
- https://github.com/pypa/advisory-database/tree/main/vulns/nuitka/PYSEC-2022-209.yaml web
- https://huntr.dev/bounties/ea4a842c-c48c-4aae-a599-3305125c63a7 web