GitHub Advisoryadvisory · npm
GHSA-4v96-m8xv-x83v Broken Authentication in Atlassian Connect Express
HIGH
Official page ↗
- Aliases
- CVE-2021-26073
- Ecosystem
- npm
- Packages
- atlassian-connect-express
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:H/A:N
- Weaknesses
- CWE-287, CWE-863
- Reviewed
- 2025-02-12
Affected packages
• npm atlassian-connect-express: >= 3.0.2, < 6.6.0 → fixed in 6.6.0
Description
Broken Authentication in Atlassian Connect Express (ACE) from version 3.0.2 before version 6.6.0: Atlassian Connect Express is a Node.js package for building Atlassian Connect apps. Authentication between Atlassian products and the Atlassian Connect Express app occurs with a server-to-server JWT or a context JWT. Atlassian Connect Express versions between 3.0.2 - 6.5.0 erroneously accept context JWTs in lifecycle endpoints (such as installation) where only server-to-server JWTs should be accepted, permitting an attacker to send authenticated re-installation events to an app.
Related
Alias · CVE (1)
- CVE-2021-26073 Broken Authentication in Atlassian Connect Express (ACE) from version 3.0.2 before version 6.6.0: Atlassian Connect Express is a Node.js… vulnerability
References
- https://nvd.nist.gov/vuln/detail/CVE-2021-26073 advisory
- https://community.developer.atlassian.com/t/action-required-atlassian-connect-vulnerability-a%5B%E2%80%A6%5Dypass-of-app-qsh-verification-via-context-jwts/47072 web
- https://confluence.atlassian.com/pages/viewpage.action?pageId=1051986099 web
- https://security.netapp.com/advisory/ntap-20210604-0004 web
- http://bitbucket.org/atlassian/atlassian-connect-express package