GitHub Advisoryadvisory · Maven
GHSA-4vf2-cm23-rf4c Incorrect Authorization in Jenkins Gerrit Trigger Plugin
MEDIUM
Official page ↗
- Aliases
- CVE-2018-1000106
- Ecosystem
- Maven
- Packages
- com.sonyericsson.hudson.plugins.gerrit:gerrit-trigger
- Severity
- Moderate
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:L
- Weaknesses
- CWE-863
- Reviewed
- 2022-11-01
Affected packages
• Maven com.sonyericsson.hudson.plugins.gerrit:gerrit-trigger: < 2.27.5 → fixed in 2.27.5
Description
An improper authorization vulnerability exists in Jenkins Gerrit Trigger Plugin 2.27.4 and earlier in GerritManagement.java, GerritServer.java, and PluginImpl.java that allows an attacker with Overall/Read access to modify the Gerrit configuration in Jenkins.
Related
Alias · CVE (1)
- CVE-2018-1000106 An improper authorization vulnerability exists in Jenkins Gerrit Trigger Plugin 2.27.4 and earlier in GerritManagement.java,… vulnerability
Weakness · CWE (1)
- CWE-863 Incorrect Authorization weakness