GitHub Advisoryadvisory · Maven
GHSA-4vjp-327p-w4qv Jenkins Templating Engine Plugin Vulnerable to Arbitrary Code Execution
HIGH
Official page ↗
- Aliases
- CVE-2025-31722
- Ecosystem
- Maven
- Packages
- org.jenkins-ci.plugins:templating-engine
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-94
- Reviewed
- 2025-04-02
Affected packages
• Maven org.jenkins-ci.plugins:templating-engine: < 2.5.4 → fixed in 2.5.4
Description
Jenkins Templating Engine Plugin allows defining libraries both in the global configuration, as well as scoped to folders containing the pipelines using them. While libraries in the global configuration can only be set up by administrators and can therefore be trusted, libraries defined in folders can be configured by users with Item/Configure permission.
In Templating Engine Plugin 2.5.3 and earlier, libraries defined in folders are not subject to sandbox protection. This vulnerability allows attackers with Item/Configure permission to execute arbitrary code in the context of the Jenkins controller JVM.
In Templating Engine Plugin 2.5.4, libraries defined in folders are subject to sandbox protection.
Related
Alias · CVE (1)
- CVE-2025-31722 In Jenkins Templating Engine Plugin 2.5.3 and earlier, libraries defined in folders are not subject to sandbox protection, allowing… vulnerability
Weakness · CWE (1)
- CWE-94 Improper Control of Generation of Code weakness