GitHub Advisoryadvisory · npm
GHSA-4vjr-crvh-383h @napi-rs/image affected by libwebp CVE
HIGH
Official page ↗
- Ecosystem
- npm
- Packages
- @napi-rs/image
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- Reviewed
- 2023-09-27
Affected packages
• npm @napi-rs/image: < 1.7.0 → fixed in 1.7.0
Description
Impact
Heap buffer overflow in `libwebp` allows a remote attacker to perform an out of bounds memory write via a crafted webp image.
References
• https://github.com/advisories/GHSA-j7hp-h8jx-5ppr
• https://blog.isosceles.com/the-webp-0day/
References
- https://github.com/Brooooooklyn/Image/security/advisories/GHSA-4vjr-crvh-383h web
- https://github.com/Brooooooklyn/Image/commit/aa07979f6cd0c534a8befea87fac1210a3b621c1 web
- https://blog.isosceles.com/the-webp-0day web
- https://github.com/Brooooooklyn/Image package
- https://github.com/Brooooooklyn/Image/releases/tag/%40napi-rs%2Fimage%401.7.0 web
- https://github.com/advisories/GHSA-j7hp-h8jx-5ppr advisory