GitHub Advisoryadvisory · Maven

GHSA-4vpr-xfrp-cj64 Spring Security's authorization rules can be misconfigured when using multiple servlets

HIGH Published 2023-07-18 Modified 2023-07-27 Official page ↗
Aliases
CVE-2023-34035
Ecosystem
Maven
Packages
org.springframework.security:spring-security-config
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
Weaknesses
CWE-863
Reviewed
2023-07-19

Affected packages

• Maven org.springframework.security:spring-security-config: >= 5.8.0, < 5.8.5 → fixed in 5.8.5 • Maven org.springframework.security:spring-security-config: >= 6.0.0, < 6.0.5 → fixed in 6.0.5 • Maven org.springframework.security:spring-security-config: >= 6.1.0, < 6.1.2 → fixed in 6.1.2

Description

Spring Security versions 5.8 prior to 5.8.5, 6.0 prior to 6.0.5, and 6.1 prior to 6.1.2 could be susceptible to authorization rule misconfiguration if the application uses requestMatchers(String) and multiple servlets, one of them being Spring MVC’s DispatcherServlet. (DispatcherServlet is a Spring MVC component that maps HTTP endpoints to methods on @Controller-annotated classes.) Specifically, an application is vulnerable when all of the following are true: • Spring MVC is on the classpath • Spring Security is securing more than one servlet in a single application (one of them being Spring MVC’s DispatcherServlet) • The application uses requestMatchers(String) to refer to endpoints that are not Spring MVC endpoints An application is not vulnerable if any of the following is true: • The application does not have Spring MVC on the classpath • The application secures no servlets other than Spring MVC’s DispatcherServlet • The application uses requestMatchers(String) only for Spring MVC endpoints

Related

Alias · CVE (1)

  • CVE-2023-34035 Spring Security versions 5.8 prior to 5.8.5, 6.0 prior to 6.0.5, and 6.1 prior to 6.1.2 could be susceptible to authorization rule… vulnerability

Weakness · CWE (1)

  • CWE-863 Incorrect Authorization weakness

References