GitHub Advisoryadvisory · Packagist

GHSA-4vr7-m8p8-434h MediaWiki Cross-site Scripting (XSS) vulnerability

MEDIUM Published 2022-05-24 Modified 2024-05-17 Official page ↗
Aliases
CVE-2020-25814
Ecosystem
Packagist
Packages
mediawiki/core
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weaknesses
CWE-79
Reviewed
2024-05-17

Affected packages

• Packagist mediawiki/core: >= 1.31.0, < 1.31.9 → fixed in 1.31.9 • Packagist mediawiki/core: >= 1.32.0, < 1.34.3 → fixed in 1.34.3 • Packagist mediawiki/core: >= 1.35.0-rc.0, < 1.35.0 → fixed in 1.35.0

Description

In MediaWiki before 1.31.9 and 1.32.x through 1.34.x before 1.34.3, XSS related to jQuery can occur. The attacker creates a message with [javascript:payload xss] and turns it into a jQuery object with mw.message().parse(). The expected result is that the jQuery object does not contain an tag (or it does not have a href attribute, or it's empty, etc.). The actual result is that the object contains an <a href ="javascript... that executes when clicked.

Related

Alias · CVE (1)

  • CVE-2020-25814 In MediaWiki before 1.31.10 and 1.32.x through 1.34.x before 1.34.4, XSS related to jQuery can occur. vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References