GitHub Advisoryadvisory · npm

GHSA-4vrv-93c7-m92j snyk Code Injection vulnerability

HIGH Published 2023-07-06 Modified 2025-04-24 Official page ↗
Aliases
CVE-2022-24441
Ecosystem
npm
Packages
snyk
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weaknesses
CWE-78, CWE-94
Reviewed
2023-07-06

Affected packages

• npm snyk: < 1.1064.0 → fixed in 1.1064.0

Description

The package snyk before 1.1064.0 is vulnerable to Code Injection when analyzing a project. An attacker who can convince a user to scan a malicious project can include commands in a build file such as build.gradle or gradle-wrapper.jar, which will be executed with the privileges of the application. This vulnerability may be triggered when running the the CLI tool directly, or when running a scan with one of the IDE plugins that invoke the Snyk CLI. Successful exploitation of this issue would likely require some level of social engineering - to coerce an untrusted project to be downloaded and analyzed via the Snyk CLI or opened in an IDE where a Snyk IDE plugin is installed and enabled. Additionally, if the IDE has a Trust feature then the target folder must be marked as ‘trusted’ in order to be vulnerable. NOTE: This issue is independent of the one reported in CVE-2022-40764, and upgrading to a fixed version for this addresses that issue as well. The affected IDE plugins and versions are: • VS Code - Affected: <=1.8.0, Fixed: 1.9.0 • IntelliJ - Affected: <=2.4.47, Fixed: 2.4.48 • Visual Studio - Affected: <=1.1.30, Fixed: 1.1.31 • Eclipse - Affected: <=v20221115.132308, Fixed: All subsequent versions • Language Server - Affected: <=v20221109.114426, Fixed: All subsequent versions

Related

Alias · CVE (1)

  • CVE-2022-24441 The package snyk before 1.1064.0 are vulnerable to Code Injection when analyzing a project. vulnerability

Weakness · CWE (2)

  • CWE-78 Improper Neutralization of Special Elements used in an OS Command weakness
  • CWE-94 Improper Control of Generation of Code weakness

References