GitHub Advisoryadvisory · Packagist
GHSA-4w32-c9g7-27qx Moodle allows reflected XSS via question bank filter
HIGH
Official page ↗
- Aliases
- CVE-2025-26530
- Ecosystem
- Packagist
- Packages
- moodle/moodle
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:H
- Weaknesses
- CWE-79
- Reviewed
- 2025-02-24
Affected packages
• Packagist moodle/moodle: >= 4.5.0-beta, < 4.5.2 → fixed in 4.5.2
• Packagist moodle/moodle: >= 4.4.0-beta, < 4.4.6 → fixed in 4.4.6
• Packagist moodle/moodle: >= 4.3.0-beta, < 4.3.10 → fixed in 4.3.10
Description
The question bank filter required additional sanitizing to prevent a reflected XSS risk.
Related
Alias · CVE (1)
- CVE-2025-26530 The question bank filter required additional sanitizing to prevent a reflected XSS risk. vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness