GitHub Advisoryadvisory · Maven
GHSA-4w4h-8qh9-342x Jenkins allows Cross-Site Scripting (XSS)
LOW
Official page ↗
- Aliases
- CVE-2012-0324
- Ecosystem
- Maven
- Packages
- org.jenkins-ci.main:jenkins-core
- Severity
- Low
- CVSS vector
- CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:N/VI:N/VA:N/SC:N/SI:L/SA:N
- Weaknesses
- CWE-79
- Reviewed
- 2025-03-12
Affected packages
• Maven org.jenkins-ci.main:jenkins-core: >= 1.425, < 1.454 → fixed in 1.454
• Maven org.jenkins-ci.main:jenkins-core: < 1.424.5 → fixed in 1.424.5
Description
Cross-site scripting (XSS) vulnerability in Jenkins before 1.454, Jenkins LTS before 1.424.5, and Jenkins Enterprise 1.400.x before 1.400.0.13 and 1.424.x before 1.424.5.1 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors, a different vulnerability than CVE-2012-0325.
Related
Alias · CVE (1)
- CVE-2012-0324 Cross-site scripting (XSS) vulnerability in Jenkins before 1.454, Jenkins LTS before 1.424.5, and Jenkins Enterprise 1.400.x before… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2012-0324 advisory
- https://github.com/jenkinsci/jenkins package
- https://web.archive.org/web/20200229025003/https://www.securityfocus.com/bid/52384 web
- http://jvn.jp/en/jp/JVN14791558/index.html web
- http://jvndb.jvn.jp/jvndb/JVNDB-2012-000022 web
- http://www.cloudbees.com/jenkins-advisory/jenkins-security-advisory-2012-03-05.cb web