GitHub Advisoryadvisory · Packagist
GHSA-4w4j-9533-82qg Moodle Cross-site Scripting (XSS)
MEDIUM
Official page ↗
- Aliases
- CVE-2020-25631
- Ecosystem
- Packagist
- Packages
- moodle/moodle
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2024-04-23
Affected packages
• Packagist moodle/moodle: >= 3.9, < 3.9.2 → fixed in 3.9.2
• Packagist moodle/moodle: >= 3.8, < 3.8.5 → fixed in 3.8.5
• Packagist moodle/moodle: >= 3.7, < 3.7.8 → fixed in 3.7.8
Description
A vulnerability was found in Moodle 3.9 to 3.9.1, 3.8 to 3.8.4 and 3.7 to 3.7.7 where it was possible to include JavaScript in a book's chapter title, which was not escaped on the "Add new chapter" page. This is fixed in 3.9.2, 3.8.5 and 3.7.8.
Related
Alias · CVE (1)
- CVE-2020-25631 A vulnerability was found in Moodle 3.9 to 3.9.1, 3.8 to 3.8.4 and 3.7 to 3.7.7 where it was possible to include JavaScript in a book's… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness