GitHub Advisoryadvisory · Packagist

GHSA-4w6c-3hcx-rfj5 MantisBT vulnerable to XSS through config_option parameter in adm_config_report.php

MEDIUM Published 2022-05-17 Modified 2025-06-09 Official page ↗
Aliases
CVE-2017-7309
Ecosystem
Packagist
Packages
mantisbt/mantisbt
Severity
Moderate
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
Weaknesses
CWE-79
Reviewed
2025-06-09

Affected packages

• Packagist mantisbt/mantisbt: < 1.3.9 → fixed in 1.3.9 • Packagist mantisbt/mantisbt: >= 2.1.0, < 2.1.3 → fixed in 2.1.3 • Packagist mantisbt/mantisbt: >= 2.2.0, < 2.2.3 → fixed in 2.2.3

Description

A cross-site scripting (XSS) vulnerability in the MantisBT Configuration Report page (adm_config_report.php) allows remote attackers to inject arbitrary code (if CSP settings permit it) through a crafted 'config_option' parameter. This is fixed in 1.3.9, 2.1.3, and 2.2.3.

Related

Alias · CVE (1)

  • CVE-2017-7309 A cross-site scripting (XSS) vulnerability in the MantisBT Configuration Report page (adm_config_report.php) allows remote attackers to… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References