GitHub Advisoryadvisory · Packagist
GHSA-4wfq-jc9h-vpcx Lack of domain validation in Druple core
MEDIUM
Official page ↗
- Aliases
- CVE-2022-25276
- Ecosystem
- Packagist
- Packages
- drupal/core
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2023-04-26
Affected packages
• Packagist drupal/core: >= 8.0.0, < 9.3.19 → fixed in 9.3.19
• Packagist drupal/core: >= 9.4.0, < 9.4.3 → fixed in 9.4.3
Description
The Media oEmbed iframe route does not properly validate the iframe domain setting, which allows embeds to be displayed in the context of the primary domain. Under certain circumstances, this could lead to cross-site scripting, leaked cookies, or other vulnerabilities.
Drupal 7 core does not include the Media module and therefore is not affected.
Related
Alias · CVE (1)
- CVE-2022-25276 The Media oEmbed iframe route does not properly validate the iframe domain setting, which allows embeds to be displayed in the context of… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness