GitHub Advisoryadvisory · Go
GHSA-4wjj-jwc9-2x96 Podman's incorrect handling of the supplementary groups may lead to data disclosure, modification
HIGH
Official page ↗
- Aliases
- CVE-2022-2989
- Ecosystem
- Go
- Packages
- github.com/containers/podman/v4, github.com/containers/podman/v3
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
- Weaknesses
- CWE-842, CWE-863
- Reviewed
- 2022-09-15
Affected packages
• Go github.com/containers/podman/v4: < 4.2.0 → fixed in 4.2.0
• Go github.com/containers/podman/v3: < 3.0.1 → fixed in 3.0.1
Description
An incorrect handling of the supplementary groups in the Podman container engine might lead to the sensitive information disclosure or possible data modification if an attacker has direct access to the affected container where supplementary groups are used to set access permissions and is able to execute a binary code in that container.
Related
Alias · CVE (1)
- CVE-2022-2989 An incorrect handling of the supplementary groups in the Podman container engine might lead to the sensitive information disclosure or… vulnerability
References
- https://nvd.nist.gov/vuln/detail/CVE-2022-2989 advisory
- https://github.com/containers/podman/pull/15618 web
- https://github.com/containers/podman/pull/15677 web
- https://github.com/containers/podman/pull/15696 web
- https://access.redhat.com/errata/RHSA-2022:7822 web
- https://access.redhat.com/errata/RHSA-2022:8008 web
- https://access.redhat.com/errata/RHSA-2022:8431 web
- https://access.redhat.com/security/cve/CVE-2022-2989 web
- https://bugzilla.redhat.com/show_bug.cgi?id=2121445 web
- https://github.com/containers/podman package
- https://www.benthamsgaze.org/2022/08/22/vulnerability-in-linux-containers-investigation-and-mitigation web