GitHub Advisoryadvisory · Maven

GHSA-4wr9-2xc6-jmg5 Session fixation vulnerability in Jenkins

HIGH Published 2022-05-24 Modified 2023-10-27 Official page ↗
Aliases
CVE-2021-21671
Ecosystem
Maven
Packages
org.jenkins-ci.main:jenkins-core
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H
Weaknesses
CWE-384
Reviewed
2022-12-16

Affected packages

• Maven org.jenkins-ci.main:jenkins-core: >= 2.292, < 2.300 → fixed in 2.300 • Maven org.jenkins-ci.main:jenkins-core: < 2.289.2 → fixed in 2.289.2

Description

Jenkins 2.299 and earlier, LTS 2.289.1 and earlier does not invalidate the previous session on login. This allows attackers to use social engineering techniques to gain administrator access to Jenkins. This vulnerability was introduced in Jenkins 2.266 and LTS 2.277.1. Jenkins 2.300, LTS 2.289.2 invalidates the previous session on login. In case of problems, administrators can choose a different implementation by setting the Java system property `hudson.security.SecurityRealm.sessionFixationProtectionMode` to `2`, or disable the fix entirely by setting that system property to `0`.

Related

Alias · CVE (1)

  • CVE-2021-21671 Jenkins 2.299 and earlier, LTS 2.289.1 and earlier does not invalidate the previous session on login. vulnerability

Weakness · CWE (1)

  • CWE-384 Session Fixation weakness

References