GitHub Advisoryadvisory · PyPI

GHSA-4xf6-xr96-7vmp Djblets Cross-site scripting Vulnerability

MEDIUM Published 2022-05-17 Modified 2024-09-20 Official page ↗
Aliases
CVE-2014-3995
Ecosystem
PyPI
Packages
Djblets
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weaknesses
CWE-79
Reviewed
2023-08-16

Affected packages

• PyPI Djblets: < 0.7.30 → fixed in 0.7.30 • PyPI Djblets: >= 0.8, < 0.8.3 → fixed in 0.8.3

Description

A cross-site scripting (XSS) vulnerability in `gravatars/templatetags/gravatars.py` in Djblets before 0.7.30 and 0.8.x before 0.8.3 for Django allows remote attackers to inject arbitrary web script or HTML via a user display name.

Related

Alias · CVE (1)

  • CVE-2014-3995 Cross-site scripting (XSS) vulnerability in gravatars/templatetags/gravatars.py in Djblets before 0.7.30 and 0.8.x before 0.8.3 for Django… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References