GitHub Advisoryadvisory · Packagist

GHSA-4xgg-rw35-7mv5 Magento Improper Authorization leads to Security feature bypass

MEDIUM Published 2024-08-14 Modified 2025-10-23 Official page ↗
Aliases
CVE-2024-39416
Ecosystem
Packagist
Packages
magento/project-community-edition, magento/community-edition
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
Weaknesses
CWE-285
Reviewed
2025-10-23

Affected packages

• Packagist magento/project-community-edition: <= 2.0.2 (no fix yet) • Packagist magento/community-edition: >= 2.4.7-beta1, < 2.4.7-p2 → fixed in 2.4.7-p2 • Packagist magento/community-edition: >= 2.4.6-p1, < 2.4.6-p7 → fixed in 2.4.6-p7 • Packagist magento/community-edition: >= 2.4.5-p1, < 2.4.5-p9 → fixed in 2.4.5-p9 • Packagist magento/community-edition: < 2.4.4-p10 → fixed in 2.4.4-p10 • Packagist magento/community-edition: 2.4.4 (no fix yet) • Packagist magento/community-edition: 2.4.5 (no fix yet) • Packagist magento/community-edition: 2.4.6 (no fix yet) • Packagist magento/community-edition: 2.4.7 (no fix yet)

Description

Magento versions 2.4.7-p1, 2.4.6-p6, 2.4.5-p8, 2.4.4-p9 and earlier are affected by an Improper Authorization vulnerability that could result in a Security feature bypass. A low-privileged attacker could leverage this vulnerability to bypass security measures and disclose minor information. Exploitation of this issue does not require user interaction.

Related

Alias · CVE (1)

  • CVE-2024-39416 Adobe Commerce versions 2.4.7-p1, 2.4.6-p6, 2.4.5-p8, 2.4.4-p9 and earlier are affected by an Improper Authorization vulnerability that… vulnerability

Weakness · CWE (1)

  • CWE-285 Improper Authorization weakness

References