GitHub Advisoryadvisory · RubyGems

GHSA-4xjh-m3qx-49wc Jekyll allows attackers to access arbitrary files by specifying a symlink

HIGH Published 2018-09-28 Modified 2023-09-05 Official page ↗
Aliases
CVE-2018-17567
Ecosystem
RubyGems
Packages
jekyll
Severity
High
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Weaknesses
CWE-59
Reviewed
2020-06-16

Affected packages

• RubyGems jekyll: < 3.6.3 → fixed in 3.6.3 • RubyGems jekyll: >= 3.7.0, < 3.7.4 → fixed in 3.7.4 • RubyGems jekyll: >= 3.8.0, < 3.8.4 → fixed in 3.8.4

Description

Jekyll through 3.6.2, 3.7.x through 3.7.3, and 3.8.x through 3.8.3 allows attackers to access arbitrary files by specifying a symlink in the `include` key in the `_config.yml` file.

Related

Alias · CVE (1)

  • CVE-2018-17567 Jekyll through 3.6.2, 3.7.x through 3.7.3, and 3.8.x through 3.8.3 allows attackers to access arbitrary files by specifying a symlink in… vulnerability

Weakness · CWE (1)

  • CWE-59 Improper Link Resolution Before File Access weakness

References