GitHub Advisoryadvisory · RubyGems

GHSA-4xqq-m2hx-25v8 REXML denial of service vulnerability

MEDIUM Published 2024-07-16 Modified 2025-11-03 Official page ↗
Aliases
CVE-2024-39908
Ecosystem
RubyGems
Packages
rexml
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L
Weaknesses
CWE-400
Reviewed
2024-07-16

Affected packages

• RubyGems rexml: < 3.3.2 → fixed in 3.3.2

Description

Impact The REXML gem before 3.3.1 has some DoS vulnerabilities when it parses an XML that has many specific characters such as ``. If you need to parse untrusted XMLs, you may be impacted to these vulnerabilities. Patches The REXML gem 3.3.2 or later include the patches to fix these vulnerabilities. Workarounds Don't parse untrusted XMLs. References • https://github.com/ruby/rexml/security/advisories/GHSA-vg3r-rm7w-2xgh : This is a similar vulnerability • https://www.ruby-lang.org/en/news/2024/07/16/dos-rexml-cve-2024-39908/

Related

Alias · CVE (1)

Weakness · CWE (1)

  • CWE-400 Uncontrolled Resource Consumption weakness

References