GitHub Advisoryadvisory · PyPI
GHSA-5239-wwwm-4pmq Pygments has Regular Expression Denial of Service (ReDoS) due to Inefficient Regex for GUID Matching
LOW
Official page ↗
- Aliases
- CVE-2026-4539
- Ecosystem
- PyPI
- Packages
- Pygments
- Severity
- Low
- CVSS vector
- CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L
- Weaknesses
- CWE-1333, CWE-400
- Reviewed
- 2026-03-24
Affected packages
• PyPI Pygments: < 2.20.0 → fixed in 2.20.0
Description
A security flaw has been discovered in pygments before 2.20.0. The impacted element is the function AdlLexer of the file pygments/lexers/archetype.py. The manipulation results in inefficient regular expression complexity. The attack is only possible with local access. The exploit has been released to the public and may be used for attacks. The project was informed of the problem early through an issue report but has not responded yet.
Related
Alias · CVE (1)
- CVE-2026-4539 A security flaw has been discovered in pygments up to 2.19.2. vulnerability
References
- https://nvd.nist.gov/vuln/detail/CVE-2026-4539 advisory
- https://github.com/pygments/pygments/issues/3058 web
- https://github.com/pygments/pygments/pull/3064 web
- https://github.com/pygments/pygments/commit/24b8aa76c6cd6d70f39c6dd605cce319c98e2ccc web
- https://github.com/pygments/pygments package
- https://github.com/pygments/pygments/releases/tag/2.20.0 web
- https://vuldb.com/?ctiid.352327 web
- https://vuldb.com/?id.352327 web
- https://vuldb.com/?submit.774685 web