GitHub Advisoryadvisory · RubyGems
GHSA-529p-jj47-w3m3 Decidim cross-site scripting (XSS) in the admin panel
MEDIUM
Official page ↗
- Aliases
- CVE-2024-27095
- Ecosystem
- RubyGems
- Packages
- decidim-admin
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:C/C:H/I:N/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2024-07-10
Affected packages
• RubyGems decidim-admin: < 0.27.6 → fixed in 0.27.6
• RubyGems decidim-admin: >= 0.28.0.rc1, < 0.28.1 → fixed in 0.28.1
Description
Impact
The admin panel is subject to potential XSS attach in case the attacker manages to modify some records being uploaded to the server.
The attacker is able to change e.g. to `` if they know how to craft these requests themselves. And then enter the returned blob ID to the form inputs manually by modifying the edit page source.
Patches
Available in versions 0.27.6 and 0.28.1.
Workarounds
Review the user accounts that have access to the admin panel (i.e. general Administrators, and participatory space's Administrators) and remove access to them if they don't need it.
References
OWASP ASVS v4.0.3-5.1.3
Related
Alias · CVE (1)
- CVE-2024-27095 Decidim is a participatory democracy framework. vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://github.com/decidim/decidim/security/advisories/GHSA-529p-jj47-w3m3 web
- https://nvd.nist.gov/vuln/detail/CVE-2024-27095 advisory
- https://github.com/decidim/decidim package
- https://github.com/decidim/decidim/releases/tag/v0.27.6 web
- https://github.com/decidim/decidim/releases/tag/v0.28.1 web
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/decidim-admin/CVE-2024-27095.yml web