GitHub Advisoryadvisory · Packagist

GHSA-52qp-jpq7-6c54 Insecure Deserialization of untrusted data in rmccue/requests

CRITICAL Published 2021-04-29 Modified 2021-04-27 Official page ↗
Aliases
CVE-2021-29476
Ecosystem
Packagist
Packages
rmccue/requests
Severity
Critical
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-502
Reviewed
2021-04-27

Affected packages

• Packagist rmccue/requests: >= 1.6.0, < 1.8.0 → fixed in 1.8.0

Description

Impact Unserialization of untrusted data. Patches The issue has been patched and users of `Requests` 1.6.0, 1.6.1 and 1.7.0 should update to version 1.8.0. References Publications about the vulnerability: • https://dannewitz.ninja/posts/php-unserialize-object-injection-yet-another-stars-rating-wordpress • https://github.com/ambionics/phpggc/issues/52 • https://blog.detectify.com/2019/07/23/improving-wordpress-plugin-security/ • https://i.blackhat.com/us-18/Thu-August-9/us-18-Thomas-Its-A-PHP-Unserialization-Vulnerability-Jim-But-Not-As-We-Know-It.pdf • https://cdn2.hubspot.net/hubfs/3853213/us-18-Thomas-It%27s-A-PHP-Unserialization-Vulnerability-Jim-But-Not-As-We-....pdf • https://2018.zeronights.ru/wp-content/uploads/materials/9%20ZN2018%20WV%20-%20PHP%20unserialize.pdf • https://medium.com/@knownsec404team/extend-the-attack-surface-of-php-deserialization-vulnerability-via-phar-d6455c6a1066#3c0f Originally fixed in WordPress 5.5.2: • https://github.com/WordPress/wordpress-develop/commit/add6bedf3a53b647d0ebda2970057912d3cd79d3 • https://wordpress.org/news/2020/10/wordpress-5-5-2-security-and-maintenance-release/ Related Security Advisories: • https://cve.mitre.org/cgi-bin/cvename.cgi?name=2020-28032 • https://nvd.nist.gov/vuln/detail/CVE-2020-28032 Notification to the Requests repo including a fix in: • https://github.com/rmccue/Requests/pull/421 and • https://github.com/rmccue/Requests/pull/422 For more information If you have any questions or comments about this advisory: • Open an issue in Request

Related

Alias · CVE (1)

  • CVE-2021-29476 Requests is a HTTP library written in PHP. vulnerability

Weakness · CWE (1)

  • CWE-502 Deserialization of Untrusted Data weakness

References