GitHub Advisoryadvisory · PyPI

GHSA-537c-gmf6-5ccf Vulnerable OpenSSL included in cryptography wheels

HIGH Published 2026-06-15 Modified 2026-06-15 Official page ↗
Ecosystem
PyPI
Packages
cryptography
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weaknesses
CWE-125, CWE-1395
Reviewed
2026-06-15

Affected packages

• PyPI cryptography: >= 0.5.0, < 48.0.1 → fixed in 48.0.1

Description

pyca/cryptography's wheels include a statically linked copy of OpenSSL. The versions of OpenSSL included in wheels prior to cryptograph 48.01 are vulnerable to a security issue. More details about the vulnerability itself can be found in https://openssl-library.org/news/secadv/20260609.txt. If you are building cryptography source ("sdist") then you are responsible for upgrading your copy of OpenSSL. Only users installing from wheels built by the cryptography project (i.e., those distributed on PyPI) need to update their cryptography versions.

Related

Weakness · CWE (2)

  • CWE-125 Out-of-bounds Read weakness
  • CWE-1395 Dependency on Vulnerable Third-Party Component weakness

References