GitHub Advisoryadvisory · Maven
GHSA-53c4-cmhf-gp7w Stored Cross-site Scripting vulnerability in Jenkins Agent Server Parameter Plugin
HIGH
Official page ↗
- Aliases
- CVE-2022-25191
- Ecosystem
- Maven
- Packages
- io.jenkins.plugins:agent-server-parameter
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-79
- Reviewed
- 2022-12-01
Affected packages
• Maven io.jenkins.plugins:agent-server-parameter: < 1.1 → fixed in 1.1
Description
Jenkins Agent Server Parameter Plugin 1.0 and earlier does not escape parameter names of agent server parameters, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Item/Configure permission.
Related
Alias · CVE (1)
- CVE-2022-25191 Jenkins Agent Server Parameter Plugin 1.0 and earlier does not escape parameter names of agent server parameters, resulting in a stored… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2022-25191 advisory
- https://github.com/jenkinsci/agent-server-parameter-plugin/commit/cd237c40c76661b5c6a05e542034746e431e706e web
- https://github.com/jenkinsci/agent-server-parameter-plugin package
- https://www.jenkins.io/security/advisory/2022-02-15/#SECURITY-2268 web