GitHub Advisoryadvisory · PyPI

GHSA-53qw-q765-4fww Denial-of-service in Django

HIGH Published 2022-01-12 Modified 2024-09-20 Official page ↗
Aliases
CVE-2021-45115
Ecosystem
PyPI
Packages
Django
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weaknesses
CWE-400
Reviewed
2022-01-12

Affected packages

• PyPI Django: >= 2.2a1, < 2.2.26 → fixed in 2.2.26 • PyPI Django: >= 3.2a1, < 3.2.11 → fixed in 3.2.11 • PyPI Django: >= 4.0a1, < 4.0.1 → fixed in 4.0.1

Description

An issue was discovered in Django 2.2 before 2.2.26, 3.2 before 3.2.11, and 4.0 before 4.0.1. `UserAttributeSimilarityValidator` incurred significant overhead in evaluating a submitted password that was artificially large in relation to the comparison values. In a situation where access to user registration was unrestricted, this provided a potential vector for a denial-of-service attack.

Related

Alias · CVE (1)

  • CVE-2021-45115 An issue was discovered in Django 2.2 before 2.2.26, 3.2 before 3.2.11, and 4.0 before 4.0.1. vulnerability

Weakness · CWE (1)

  • CWE-400 Uncontrolled Resource Consumption weakness

References