GitHub Advisoryadvisory · RubyGems

GHSA-543v-gj2c-r3ch activemodel contains Improper Input Validation

MEDIUM Published 2017-10-24 Modified 2023-06-30 Official page ↗
Aliases
CVE-2016-0753
Ecosystem
RubyGems
Packages
activemodel
Severity
Moderate
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
Weaknesses
CWE-20
Reviewed
2020-06-16

Affected packages

• RubyGems activemodel: >= 4.1.0, < 4.1.14.1 → fixed in 4.1.14.1 • RubyGems activemodel: >= 4.2.0, < 4.2.5.1 → fixed in 4.2.5.1

Description

Active Model in Ruby on Rails 4.1.x before 4.1.14.1, 4.2.x before 4.2.5.1, and 5.x before 5.0.0.beta1.1 supports the use of instance-level writers for class accessors, which allows remote attackers to bypass intended validation steps via crafted parameters.

Related

Alias · CVE (1)

  • CVE-2016-0753 Active Model in Ruby on Rails 4.1.x before 4.1.14.1, 4.2.x before 4.2.5.1, and 5.x before 5.0.0.beta1.1 supports the use of instance-level… vulnerability

Weakness · CWE (1)

  • CWE-20 Improper Input Validation weakness

References