GitHub Advisoryadvisory · Go

GHSA-5465-xc2j-6p84 github.com/openshift/apiserver-library-go Improper Input Validation vulnerability

MEDIUM Published 2023-01-26 Modified 2024-05-20 Official page ↗
Aliases
CVE-2023-0229
Ecosystem
Go
Packages
github.com/openshift/apiserver-library-go
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
Weaknesses
CWE-20
Reviewed
2023-02-08

Affected packages

• Go github.com/openshift/apiserver-library-go: < 0.0.0-20230120221150-cefee9e0162b → fixed in 0.0.0-20230120221150-cefee9e0162b

Description

A flaw was found in github.com/openshift/apiserver-library-go, used in OpenShift 4.12 and 4.11, that contains an issue that can allow low-privileged users to set the seccomp profile for pods they control to "unconfined." By default, the seccomp profile used in the restricted-v2 Security Context Constraint (SCC) is "runtime/default," allowing users to disable seccomp for pods they can create and modify.

Related

Alias · CVE (1)

  • CVE-2023-0229 A flaw was found in github.com/openshift/apiserver-library-go, used in OpenShift 4.12 and 4.11, that contains an issue that can allow… vulnerability

Weakness · CWE (1)

  • CWE-20 Improper Input Validation weakness

References