GitHub Advisoryadvisory · NuGet
GHSA-555c-2p6r-68mm .NET Denial of Service vulnerability
HIGH
Official page ↗
- Aliases
- CVE-2023-29331
- Ecosystem
- NuGet
- Packages
- Microsoft.Windows.Compatibility, System.Security.Cryptography.Pkcs, Microsoft.NETCore.App.Runtime.linux-arm, Microsoft.NETCore.App.Runtime.linux-arm64, Microsoft.NETCore.App.Runtime.linux-musl-arm, Microsoft.NETCore.App.Runtime.linux-musl-arm64, Microsoft.NETCore.App.Runtime.linux-musl-x64, Microsoft.NETCore.App.Runtime.linux-x64, Microsoft.NETCore.App.Runtime.osx-arm64, Microsoft.NETCore.App.Runtime.osx-x64, Microsoft.NETCore.App.Runtime.win-arm, Microsoft.NETCore.App.Runtime.win-arm64, Microsoft.NETCore.App.Runtime.win-x64, Microsoft.NETCore.App.Runtime.win-x86
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-400
- Reviewed
- 2023-06-14
Affected packages
• NuGet Microsoft.Windows.Compatibility: >= 7.0.0, < 7.0.3 → fixed in 7.0.3
• NuGet Microsoft.Windows.Compatibility: >= 6.0.0, < 6.0.6 → fixed in 6.0.6
• NuGet System.Security.Cryptography.Pkcs: >= 7.0.0, < 7.0.2 → fixed in 7.0.2
• NuGet System.Security.Cryptography.Pkcs: >= 6.0.0, < 6.0.3 → fixed in 6.0.3
• NuGet Microsoft.NETCore.App.Runtime.linux-arm: >= 7.0.0, < 7.0.7 → fixed in 7.0.7
• NuGet Microsoft.NETCore.App.Runtime.linux-arm: >= 6.0.0, < 6.0.18 → fixed in 6.0.18
• NuGet Microsoft.NETCore.App.Runtime.linux-arm64: >= 6.0.0, < 6.0.18 → fixed in 6.0.18
• NuGet Microsoft.NETCore.App.Runtime.linux-arm64: >= 7.0.0, < 7.0.7 → fixed in 7.0.7
• NuGet Microsoft.NETCore.App.Runtime.linux-musl-arm: >= 7.0.0, < 7.0.7 → fixed in 7.0.7
• NuGet Microsoft.NETCore.App.Runtime.linux-musl-arm: >= 6.0.0, < 6.0.18 → fixed in 6.0.18
• NuGet Microsoft.NETCore.App.Runtime.linux-musl-arm64: >= 7.0.0, < 7.0.7 → fixed in 7.0.7
• NuGet Microsoft.NETCore.App.Runtime.linux-musl-arm64: >= 6.0.0, < 6.0.18 → fixed in 6.0.18
• NuGet Microsoft.NETCore.App.Runtime.linux-musl-x64: >= 6.0.0, < 6.0.18 → fixed in 6.0.18
• NuGet Microsoft.NETCore.App.Runtime.linux-musl-x64: >= 7.0.0, < 7.0.7 → fixed in 7.0.7
• NuGet Microsoft.NETCore.App.Runtime.linux-x64: >= 6.0.0, < 6.0.18 → fixed in 6.0.18
• NuGet Microsoft.NETCore.App.Runtime.linux-x64: >= 7.0.0, < 7.0.7 → fixed in 7.0.7
• NuGet Microsoft.NETCore.App.Runtime.osx-arm64: >= 6.0.0, < 6.0.18 → fixed in 6.0.18
• NuGet Microsoft.NETCore.App.Runtime.osx-arm64: >= 7.0.0, < 7.0.7 → fixed in 7.0.7
• NuGet Microsoft.NETCore.App.Runtime.osx-x64: >= 6.0.0, < 6.0.18 → fixed in 6.0.18
• NuGet Microsoft.NETCore.App.Runtime.osx-x64: >= 7.0.0, < 7.0.7 → fixed in 7.0.7
• NuGet Microsoft.NETCore.App.Runtime.win-arm: >= 6.0.0, < 6.0.18 → fixed in 6.0.18
• NuGet Microsoft.NETCore.App.Runtime.win-arm: >= 7.0.0, < 7.0.7 → fixed in 7.0.7
• NuGet Microsoft.NETCore.App.Runtime.win-arm64: >= 6.0.0, < 6.0.18 → fixed in 6.0.18
• NuGet Microsoft.NETCore.App.Runtime.win-arm64: >= 7.0.0, < 7.0.7 → fixed in 7.0.7
• NuGet Microsoft.NETCore.App.Runtime.win-x64: >= 6.0.0, < 6.0.18 → fixed in 6.0.18
• NuGet Microsoft.NETCore.App.Runtime.win-x64: >= 7.0.0, < 7.0.7 → fixed in 7.0.7
• NuGet Microsoft.NETCore.App.Runtime.win-x86: >= 7.0.0, < 7.0.7 → fixed in 7.0.7
• NuGet Microsoft.NETCore.App.Runtime.win-x86: >= 6.0.0, < 6.0.18 → fixed in 6.0.18
Description
Microsoft Security Advisory CVE-2023-29331: .NET Denial of Service vulnerability
Executive summary
Microsoft is releasing this security advisory to provide information about a vulnerability in .NET 7.0 and .NET 6.0. This advisory also provides guidance on what developers can do to update their applications to remove this vulnerability.
A vulnerability exists in .NET when processing X.509 certificates that may result in Denial of Service.
Details: KB5025823
Announcement
Announcement for this issue can be found at https://github.com/dotnet/announcements/issues/257
Mitigation factors
Microsoft has not identified any mitigating factors for this vulnerability.
Affected software
• Any .NET 7.0 application running on .NET 7.0.5 or earlier.
• Any .NET 6.0 application running on .NET 6.0.16 or earlier.
If your application uses the following package versions, ensure you update to the latest version of .NET.
.NET 7
Package name | Affected version | Patched version
------------ | ---------------- | -------------------------
Microsoft.Windows.Compatibility | >= 7.0.0, = 7.0.0, = 7.0.0, = 7.0.0, = 7.0.0, = 7.0.0, = 7.0.0, = 7.0.0, = 7.0.0, = 7.0.0, = 7.0.0, = 7.0.0, = 7.0.0, = 7.0.0, .NET 6
Package name | Affected version | Patched version
------------ | ---------------- | -------------------------
Microsoft.Windows.Compatibility | >= 6.0.0, = 6.0.0, = 6.0.0, = 6.0.0, = 6.0.1, = 6.0.0, = 6.0.0, = 6.0.0, = 6.0.0, = 6.0.0, = 6.0.0, = 6.0.0, = 6.0.0, = 6.0.0, How do I know if I am affected?
If you have a runtime or SDK with a version listed, or an affected package listed in affected software, you're exposed to the vulnerability.
How do I fix the issue?
• To fix the issue please install the latest version of .NET 6.0 or .NET 7.0. If you have installed one or more .NET SDKs through Visual Studio, Visual Studio will prompt you to update Visual Studio, which will also update your .NET SDKs.
• If you are using one of the affected packages, please update to the patched version listed above.
• If you have .NET 6.0 or greater installed, you can list the versions you have installed by running the `dotnet --info` command. You will see output like the following;
```
.NET Core SDK (reflecting any global.json):
Version: 6.0.300
Commit: 8473146e7d
Runtime Environment:
OS Name: Windows
OS Version: 10.0.18363
OS Platform: Windows
RID: win10-x64
Base Path: C:\Program Files\dotnet\sdk\6.0.300\
Host (useful for support):
Version: 6.0.5
Commit: 8473146e7d
.NET Core SDKs installed:
6.0.300 [C:\Program Files\dotnet\sdk]
.NET Core runtimes installed:
Microsoft.AspNetCore.App 6.0.5 [C:\Program Files\dotnet\shared\Microsoft.AspNetCore.App]
Microsoft.NETCore.App 6.0.5 [C:\Program Files\dotnet\shared\Microsoft.NETCore.App]
Microsoft.WindowsDesktop.App 6.0.5 [C:\Program Files\dotnet\shared\Microsoft.WindowsDesktop.App]
To install additional .NET Core runtimes or SDKs:
https://aka.ms/dotnet-download
```
• If you're using .NET 7.0, you should download and install Runtime 7.0.7 or SDK 7.0.106 (for Visual Studio 2022 v17.4) from https://dotnet.microsoft.com/download/dotnet-core/7.0.
• If you're using .NET 6.0, you should download and install Runtime 6.0.18 or SDK 6.0.312 (for Visual Studio 2022 v17.2) from https://dotnet.microsoft.com/download/dotnet-core/6.0.
.NET 6.0 and and .NET 7.0 updates are also available from Microsoft Update. To access this either type "Check for updates" in your Windows search, or open Settings, choose Update & Security and then click Check for Updates.
Once you have installed the updated runtime or SDK, restart your apps for the update to take effect.
Additionally, if you've deployed [self-contained…
Related
Alias · CVE (1)
- CVE-2023-29331 .NET, .NET Framework, and Visual Studio Denial of Service Vulnerability vulnerability
Weakness · CWE (1)
- CWE-400 Uncontrolled Resource Consumption weakness
References
- https://github.com/dotnet/runtime/security/advisories/GHSA-555c-2p6r-68mm web
- https://nvd.nist.gov/vuln/detail/CVE-2023-29331 advisory
- https://github.com/dotnet/announcements/issues/257 web
- https://github.com/dotnet/runtime package
- https://msrc.microsoft.com/update-guide/vulnerability/CVE-2023-29331 web
- https://support.microsoft.com/kb/5025823 web