GitHub Advisoryadvisory · Packagist

GHSA-5632-wq7m-gfq9 Magento Open Source Cross-Site Scripting (XSS) vulnerability

MEDIUM Published 2024-06-13 Modified 2024-08-07 Official page ↗
Aliases
CVE-2024-34105
Ecosystem
Packagist
Packages
magento/community-edition
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
Weaknesses
CWE-79
Reviewed
2024-08-07

Affected packages

• Packagist magento/community-edition: 2.4.7 (no fix yet) • Packagist magento/community-edition: 2.4.6 (no fix yet) • Packagist magento/community-edition: 2.4.5 (no fix yet) • Packagist magento/community-edition: 2.4.4 (no fix yet) • Packagist magento/community-edition: >= 2.4.6-p1, < 2.4.6-p6 → fixed in 2.4.6-p6 • Packagist magento/community-edition: >= 2.4.5-p1, < 2.4.5-p8 → fixed in 2.4.5-p8 • Packagist magento/community-edition: < 2.4.4-p9 → fixed in 2.4.4-p9

Description

Adobe Commerce versions 2.4.7, 2.4.6-p5, 2.4.5-p7, 2.4.4-p8 and earlier are affected by a stored Cross-Site Scripting (XSS) vulnerability that could be abused by an admin attacker to inject malicious scripts into vulnerable form fields. Malicious JavaScript may be executed in a victim’s browser when they browse to the page containing the vulnerable field.

Related

Alias · CVE (1)

  • CVE-2024-34105 Adobe Commerce versions 2.4.7, 2.4.6-p5, 2.4.5-p7, 2.4.4-p8 and earlier are affected by a stored Cross-Site Scripting (XSS) vulnerability… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References