GitHub Advisoryadvisory · npm
GHSA-5635-9mvj-r6hp Malicious Package in vue-backbone
CRITICAL
Official page ↗
- Ecosystem
- npm
- Packages
- vue-backbone
- Severity
- Critical
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-506
- Reviewed
- 2020-08-31
Affected packages
• npm vue-backbone: >= 0.1.2, < 0.1.3 → fixed in 0.1.3
Description
Version 0.1.2 of `vue-backbone` contained malicious code. The code when executed in the browser would enumerate password, cvc and cardnumber fields from forms and send the extracted values to `https://js-metrics.com/minjs.php?pl=`
Recommendation
Remove the package from your environment and evaluate your application to determine whether or not user data was compromised.
Related
Weakness · CWE (1)
- CWE-506 Embedded Malicious Code weakness