GitHub Advisoryadvisory · Maven

GHSA-563x-q5rq-57qp Apache Tomcat has an HTTP Request/Response Smuggling vulnerability

HIGH Published 2026-04-09 Modified 2026-05-20 Official page ↗
Aliases
CVE-2026-24880
Ecosystem
Maven
Packages
org.apache.tomcat:tomcat-coyote, org.apache.tomcat.embed:tomcat-embed-core
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Weaknesses
CWE-444
Reviewed
2026-04-10

Affected packages

• Maven org.apache.tomcat:tomcat-coyote: >= 7.0.0, < 9.0.116 → fixed in 9.0.116 • Maven org.apache.tomcat:tomcat-coyote: >= 10.1.0-M1, < 10.1.52 → fixed in 10.1.52 • Maven org.apache.tomcat:tomcat-coyote: >= 11.0.0-M1, < 11.0.20 → fixed in 11.0.20 • Maven org.apache.tomcat.embed:tomcat-embed-core: >= 7.0.0, < 9.0.116 → fixed in 9.0.116 • Maven org.apache.tomcat.embed:tomcat-embed-core: >= 10.1.0-M1, < 10.1.52 → fixed in 10.1.52 • Maven org.apache.tomcat.embed:tomcat-embed-core: >= 11.0.0-M1, < 11.0.20 → fixed in 11.0.20

Description

Inconsistent Interpretation of HTTP Requests ('HTTP Request/Response Smuggling') vulnerability in Apache Tomcat via invalid chunk extension. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.18, from 10.1.0-M1 through 10.1.52, from 9.0.0.M1 through 9.0.115, from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109. Other, unsupported versions may also be affected. Users are recommended to upgrade to version 11.0.20, 10.1.52 or 9.0.116, which fix the issue.

Related

Alias · CVE (1)

  • CVE-2026-24880 Inconsistent Interpretation of HTTP Requests ('HTTP Request/Response Smuggling') vulnerability in Apache Tomcat via invalid chunk extension. vulnerability

Weakness · CWE (1)

  • CWE-444 Inconsistent Interpretation of HTTP Requests weakness

References