GitHub Advisoryadvisory · Packagist

GHSA-5659-g9p4-354f Moodle allows attackers to bypass a forced-password-change requirement

MEDIUM Published 2022-05-13 Modified 2024-01-25 Official page ↗
Aliases
CVE-2015-2272
Ecosystem
Packagist
Packages
moodle/moodle
Severity
Moderate
Reviewed
2024-01-25

Affected packages

• Packagist moodle/moodle: < 2.6.9 → fixed in 2.6.9 • Packagist moodle/moodle: >= 2.7.0, < 2.7.6 → fixed in 2.7.6 • Packagist moodle/moodle: >= 2.8.0, < 2.8.4 → fixed in 2.8.4

Description

login/token.php in Moodle through 2.5.9, 2.6.x before 2.6.9, 2.7.x before 2.7.6, and 2.8.x before 2.8.4 allows remote authenticated users to bypass a forced-password-change requirement by creating a web-services token.

Related

Alias · CVE (1)

  • CVE-2015-2272 login/token.php in Moodle through 2.5.9, 2.6.x before 2.6.9, 2.7.x before 2.7.6, and 2.8.x before 2.8.4 allows remote authenticated users… vulnerability

References