GitHub Advisoryadvisory · Packagist
GHSA-56fm-hfp3-x3w3 Wallabag user can disable 2FA unintentionally
MEDIUM
Official page ↗
- Ecosystem
- Packagist
- Packages
- wallabag/wallabag
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N
- Reviewed
- 2023-10-02
Affected packages
• Packagist wallabag/wallabag: >= 2.0.0-alpha.1, < 2.6.7 → fixed in 2.6.7
Description
Impact
wallabag was discovered to contain a Cross-Site Request Forgery (CSRF) which allows attackers to arbitrarily disable 2FA through `/config/otp/app/disable` and `/config/otp/email/disable`.
This vulnerability has a CVSSv3.1 score of 4.3.
You should upgrade your instance to version 2.6.7 or higher.
Resolution
These endpoints now require POST method.
Credits
We would like to thank @dhina016 for reporting this issue through huntr.dev.
Reference: https://huntr.dev/bounties/4c446fe7-2a44-4907-b0cf-4ab77d75c487/