GitHub Advisoryadvisory · Maven

GHSA-56jp-w6vw-j3jw Apache James vulnerable to denial of service through the use of IMAP literals

HIGH Published 2025-02-06 Modified 2025-02-06 Official page ↗
Aliases
CVE-2024-37358
Ecosystem
Maven
Packages
org.apache.james.protocols:protocols-imap
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:H
Weaknesses
CWE-20, CWE-400, CWE-770
Reviewed
2025-02-06

Affected packages

• Maven org.apache.james.protocols:protocols-imap: < 3.7.6 → fixed in 3.7.6 • Maven org.apache.james.protocols:protocols-imap: >= 3.8.0, < 3.8.2 → fixed in 3.8.2

Description

Similarly to CVE-2024-34055, Apache James is vulnerable to denial of service through the abuse of IMAP literals from both authenticated and unauthenticated users, which could be used to cause unbounded memory allocation and very long computations Version 3.7.6 and 3.8.2 restrict such illegitimate use of IMAP literals.

Related

Alias · CVE (1)

  • CVE-2024-37358 Similarly to CVE-2024-34055, Apache James is vulnerable to denial of service through the abuse of IMAP literals from both authenticated and… vulnerability

Weakness · CWE (3)

  • CWE-20 Improper Input Validation weakness
  • CWE-400 Uncontrolled Resource Consumption weakness
  • CWE-770 Allocation of Resources Without Limits or Throttling weakness

References